System requirements

You can host or attend a Lumen Workplace℠ meeting in a web browser or the desktop and mobile apps.

Jump to: Web | Desktop apps | Mobile apps | Outlook

Web

To host or attend a meeting in a web browser, you must have:

  • Windows 10
  • macOS 10.11 or newer
  • JavaScript® and cookies enabled
  • Internet Explorer 11. When prompted, install the Audio & Video plugin. This enables VoIP audio, webcam, and screen sharing in IE.
  • Google Chrome 72 or newer
  • Microsoft Edge 79 or newer
  • Mozilla Firefox 68 or newer

If prompted, allow Lumen Workplace to access your mic (for VoIP audio) and webcam.

▲ top

Desktop apps

The Lumen Workplace desktop apps are available for Mac and Windows computers.

  • Windows 10
  • macOS 10.11 or newer
  • Minimum 1.6 GHz (or higher), 2 core or better
  • 4 GB RAM

For a better experience with video calls and online sharing, we recommend using a computer that has a 2.0 GHz processor and 4 GB RAM (or more).

▲ top

Mobile apps

The Lumen Workplace mobile apps are available for Apple iOS devices and Android smartphones.

  • iPhone and iPod Touch devices running iOS 12 and newer. Compatible with iPhone 5s and newer. iPhone 6s and newer recommended.
  • iPad devices running iOS 12 and iPadOS 13 and newer. Compatible with iPad (5th and 6th gen), iPad mini (2nd - 5th gen; 4th and 5th recommended), iPad Air (all generations; 2nd and 3rd recommended), and iPad Pro.
  • Android smartphones running Android platform versions 6.0 and newer (Marshmallow and newer). Android tablets are not supported.
  • You must have an active data connection, either through your wireless carrier’s network or via Wi-Fi.

▲ top

Meetings add-in for Outlook

The Meetings add-in for Outlook is available for Microsoft Outlook for Mac 2016; Outlook for Windows 2013, 2016, and 2019; and Outlook on the web.

  • Windows 8.1 or Windows 10
  • macOS 10.11 or newer
  • A Microsoft Exchange mailbox:
    • Mac and Windows: Outlook.com, Office 365, or Exchange 2013
    • Web: Outlook.com, Office 365, or Exchange 2016
  • Additional requirements:
    • Reading pane displayed in Outlook
    • Permission to install Outlook add-ins via a URL
    • Windows: Internet Explorer 10 or newer

▲ top